<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
					<head>
				    <meta charset="UTF-8" />
				    <meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7; IE=EDGE" />
            				    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
				    <link rel="profile" href="http://gmpg.org/xfn/11" />
				    <link rel="pingback" href="http://www.signaltribunenewspaper.com/xmlrpc.php" />

				   <!-- html5shiv for IE8 and less  -->
				    <!--[if lt IE 9]>
				      <script src="http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/js/html5.js"></script>
				    <![endif]-->
				    <title>Larger Than Life &#8211; Signal Tribune Newspaper</title>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.signaltribunenewspaper.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Signal Tribune Newspaper &raquo; Feed" href="http://www.signaltribunenewspaper.com/?feed=rss2" />
<link rel="alternate" type="application/rss+xml" title="Signal Tribune Newspaper &raquo; Comments Feed" href="http://www.signaltribunenewspaper.com/?feed=comments-rss2" />
<link rel="alternate" type="application/rss+xml" title="Signal Tribune Newspaper &raquo; Larger Than Life Comments Feed" href="http://www.signaltribunenewspaper.com/?feed=rss2&#038;p=25089" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.signaltribunenewspaper.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.3"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tc-gfonts-css'  href='//fonts.googleapis.com/css?family=EB+Garamond|EB+Garamond' type='text/css' media='all' />
<link rel='stylesheet' id='st-widget-css'  href='http://www.signaltribunenewspaper.com/wp-content/plugins/share-this/css/style.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='social-widget-css'  href='http://www.signaltribunenewspaper.com/wp-content/plugins/social-media-widget/social_widget.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://www.signaltribunenewspaper.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.1' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('http://www.signaltribunenewspaper.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='ai-core-style-css'  href='http://www.signaltribunenewspaper.com/wp-content/plugins/aesop-story-engine/public/assets/css/ai-core.css?ver=1' type='text/css' media='all' />
<style id='ai-core-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='customizr-common-css'  href='http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/css/tc_common.min.css?ver=3.4.33' type='text/css' media='all' />
<link rel='stylesheet' id='customizr-skin-css'  href='http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/css/red.min.css?ver=3.4.33' type='text/css' media='all' />
<style id='customizr-skin-inline-css' type='text/css'>
        @font-face {
          font-family: 'FontAwesome';
          src:url('http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/css/fonts/fonts/fontawesome-webfont.eot');
          src:url('http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/css/fonts/fonts/fontawesome-webfont.eot?#iefix') format('embedded-opentype'),
              url('http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/css/fonts/fonts/fontawesome-webfont.woff2') format('woff2'),
              url('http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/css/fonts/fonts/fontawesome-webfont.woff') format('woff'),
              url('http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/css/fonts/fonts/fontawesome-webfont.ttf') format('truetype'),
              url('http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/css/fonts/fonts/fontawesome-webfont.svg#fontawesomeregular') format('svg');
        }
        

                .site-title,.site-description,h1,h2,h3,.tc-dropcap {
                  font-family : 'EB Garamond';
                  font-weight : inherit;
                }

                body,.navbar .nav>li>a {
                  font-family : 'EB Garamond';
                  font-weight : inherit;
                }

          body,.navbar .nav>li>a {
            font-size : 18px;
            line-height : 24px;
          }
table { border-collapse: separate; }
                         body table { border-collapse: collapse; }
                        

      .carousel .item {
        line-height: 450px;
        min-height:450px;
        max-height:450px;
      }
      .tc-slider-loader-wrapper {
        line-height: 450px;
        height:450px;
      }
      .carousel .tc-slider-controls {
        line-height: 450px;
        max-height:450px;
      }

        @media (max-width: 1200px) {
          .carousel .item {
            line-height: 346.5px;
            max-height:346.5px;
            min-height:346.5px;
          }
          .item .carousel-caption {
            max-height: 301.5px;
            overflow: hidden;
          }
          .carousel .tc-slider-loader-wrapper {
            line-height: 346.5px;
            height:346.5px;
          }
        }

        @media (max-width: 979px) {
          .carousel .item {
            line-height: 278.1px;
            max-height:278.1px;
            min-height:278.1px;
          }
          .item .carousel-caption {
            max-height: 233.1px;
            overflow: hidden;
          }
          .carousel .tc-slider-loader-wrapper {
            line-height: 278.1px;
            height:278.1px;
          }
        }

        @media (max-width: 480px) {
          .carousel .item {
            line-height: 171px;
            max-height:171px;
            min-height:171px;
          }
          .item .carousel-caption {
            max-height: 126px;
            overflow: hidden;
          }
          .carousel .tc-slider-loader-wrapper {
            line-height: 171px;
            height:171px;
          }
        }

        @media (max-width: 320px) {
          .carousel .item {
            line-height: 126px;
            max-height:126px;
            min-height:126px;
          }
          .item .carousel-caption {
            max-height: 81px;
            overflow: hidden;
          }
          .carousel .tc-slider-loader-wrapper {
            line-height: 126px;
            height:126px;
          }
        }

body
{
font-color: #000000;
}

h1
{
font-color: #8B0000;
}
skin
{
color: #8B0000;
}


</style>
<link rel='stylesheet' id='customizr-style-css'  href='http://www.signaltribunenewspaper.com/wp-content/themes/customizr/style.css?ver=3.4.33' type='text/css' media='all' />
<link rel='stylesheet' id='fancyboxcss-css'  href='http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/js/fancybox/jquery.fancybox-1.3.4.min.css?ver=4.6.3' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='sccss_style-css'  href='http://www.signaltribunenewspaper.com?sccss=1&#038;ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.signaltribunenewspaper.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.3.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/plugins/wp-content-slideshow-reborn/scripts/jquery.cycle.all.2.72.js?ver=1.3'></script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/plugins/wp-content-slideshow-reborn/scripts/slideshow.js?ver=1.3'></script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/js/fancybox/jquery.fancybox-1.3.4.min.js?ver=3.4.33'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var TCParams = {"_disabled":[],"FancyBoxState":"1","FancyBoxAutoscale":"1","SliderName":"","SliderDelay":"","SliderHover":"1","centerSliderImg":"1","SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"anchorSmoothScroll":"linear","anchorSmoothScrollExclude":{"simple":["[class*=edd]",".tc-carousel-control",".carousel-control","[data-toggle=\"modal\"]","[data-toggle=\"dropdown\"]","[data-toggle=\"tooltip\"]","[data-toggle=\"popover\"]","[data-toggle=\"collapse\"]","[data-toggle=\"tab\"]","[class*=upme]","[class*=um-]"],"deep":{"classes":[],"ids":[]}},"ReorderBlocks":"1","centerAllImg":"1","HasComments":"1","LeftSidebarClass":".span3.left.tc-sidebar","RightSidebarClass":".span3.right.tc-sidebar","LoadModernizr":"1","stickyCustomOffset":{"_initial":0,"_scrolling":0,"options":{"_static":true,"_element":""}},"stickyHeader":"","dropdowntoViewport":"0","timerOnScrollAllBrowsers":"1","extLinksStyle":"0","extLinksTargetExt":"0","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"dropcapEnabled":"","dropcapWhere":{"post":"","page":""},"dropcapMinWords":"1","dropcapSkipSelectors":{"tags":["IMG","IFRAME","H1","H2","H3","H4","H5","H6","BLOCKQUOTE","UL","OL"],"classes":["btn"],"id":[]},"imgSmartLoadEnabled":"","imgSmartLoadOpts":{"parentSelectors":[".article-container",".__before_main_wrapper",".widget-front"],"opts":{"excludeImg":[".tc-holder-img"]}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","isSecondMenuEnabled":"","secondMenuRespSet":"in-sn-before"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/js/tc-scripts.min.js?ver=3.4.33'></script>
<link rel='https://api.w.org/' href='http://www.signaltribunenewspaper.com/?rest_route=/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.signaltribunenewspaper.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.signaltribunenewspaper.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='City of Long Beach plans community review process for Civic Center request for proposals' href='http://www.signaltribunenewspaper.com/?p=25087' />
<link rel='next' title='LBPD makes three arrests, 19 citations at checkpoint' href='http://www.signaltribunenewspaper.com/?p=25091' />
<meta name="generator" content="WordPress 4.6.3" />
<link rel="canonical" href="http://www.signaltribunenewspaper.com/?p=25089&#038;cpage=1#comments" />
<link rel='shortlink' href='http://wp.me/p6rhu-6wF' />
<link rel="alternate" type="application/json+oembed" href="http://www.signaltribunenewspaper.com/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.signaltribunenewspaper.com%2F%3Fp%3D25089" />
<link rel="alternate" type="text/xml+oembed" href="http://www.signaltribunenewspaper.com/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.signaltribunenewspaper.com%2F%3Fp%3D25089&#038;format=xml" />
<script charset="utf-8" type="text/javascript">var switchTo5x=true;</script><script charset="utf-8" type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script><script type="text/javascript">stLight.options({publisher:'wp.e03df59c-30f4-499d-bb42-71523857a5e1'});var st_type='wordpress4.3.1';</script>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Larger Than Life" />
<meta property="og:url" content="http://www.signaltribunenewspaper.com/?p=25089" />
<meta property="og:description" content="Ashley Fowler Staff Writer Signal Hill has hosted a number of colorful characters over the years. Among them, the memory of the multifaceted “Kid Mexico” lives on. Tod “Kid Mexico” Faulkner was bor…" />
<meta property="article:published_time" content="2014-09-12T17:21:34+00:00" />
<meta property="article:modified_time" content="2014-09-12T17:21:34+00:00" />
<meta property="og:site_name" content="Signal Tribune Newspaper" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />

<style id="custom-css-css">h1{font-family:Georgia}</style>
<style id="tt-easy-google-font-styles" type="text/css">p { }
h1 { }
h2 { }
h3 { }
h4 { }
h5 { }
h6 { }
</style>				</head>
				
	<body class="single single-post postid-25089 single-format-standard browser-unknown aesop-core aesop-on-customizr tc-fade-hover-links tc-no-sidebar tc-no-sticky-header skin-red tc-center-images tc-regular-menu" itemscope itemtype="http://schema.org/WebPage">

    
    <div id="tc-page-wrap" class="">

  		
  	   	<header class="tc-header clearfix row-fluid tc-tagline-off tc-title-logo-on  tc-shrink-off tc-menu-off logo-left tc-second-menu-in-sn-before-when-mobile" role="banner">
  			
        <div class="brand span3 pull-left">
        <a class="site-logo" href="http://www.signaltribunenewspaper.com/" title="Signal Tribune Newspaper | 939 E. 27th St. Signal Hill, CA 90755  • (562) 595-7900 • Advertising contact •  advertising@signaltribune.com"><img src="http://www.signaltribunenewspaper.com/wp-content/uploads/2017/01/Signal-logo.png" alt="Back Home" width="247" height="86" style="max-width:250px;max-height:100px" data-no-retina class=" attachment-32989"/></a>        </div> <!-- brand span3 -->

        <div class="container outside"><h2 class="site-description">939 E. 27th St. Signal Hill, CA 90755  • (562) 595-7900 • Advertising contact •  advertising@signaltribune.com</h2></div>      	<div class="navbar-wrapper clearfix span9 tc-submenu-fade tc-submenu-move tc-open-on-hover pull-menu-right">
        	<div class="navbar resp">
          		<div class="navbar-inner" role="navigation">
            		<div class="row-fluid">
              		<div class="social-block span5" ><a class="social-icon icon-feed" href="http://www.signaltribunenewspaper.com/?feed=rss" title="Subscribe to my rss feed"  ></a><a class="social-icon icon-twitter" href="https://twitter.com/SignalTribune" title="Follow me on Twitter" target=_blank ></a><a class="social-icon icon-facebook" href="https://www.facebook.com/signal.tribune" title="Follow me on Facebook" target=_blank ></a><a class="social-icon icon-youtube" href="https://www.youtube.com/channel/UCURvDuI0JRY7wbkhQ52w1Ew" title="Follow me on Youtube" target=_blank ></a><a class="social-icon icon-linkedin" href="https://www.linkedin.com/pub/neena-strichart/80/5b1/5ba" title="Follow me on LinkedIn" target=_blank ></a></div><h2 class="span7 inside site-description">939 E. 27th St. Signal Hill, CA 90755  • (562) 595-7900 • Advertising contact •  advertising@signaltribune.com</h2><div class="nav-collapse collapse tc-hover-menu-wrapper"><div class="menu-menu-1-container"><ul id="menu-menu-3" class="nav tc-hover-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-26776"><a href="http://www.signaltribunenewspaper.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-26777"><a data-test="joie" href="http://www.signaltribunenewspaper.com/?page_id=3">Advertising <strong class="caret"></strong></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28694"><a href="http://www.signaltribunenewspaper.com/?cat=629">Our Ads</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-26780"><a data-test="joie" href="http://www.signaltribunenewspaper.com/?cat=6">News <strong class="caret"></strong></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26785"><a href="http://www.signaltribunenewspaper.com/?cat=482">Eye On Crime</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-26781"><a data-test="joie" href="http://www.signaltribunenewspaper.com/?cat=8">Community <strong class="caret"></strong></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26786"><a href="http://www.signaltribunenewspaper.com/?cat=11">Focus On Business</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-26782"><a data-test="joie" href="http://www.signaltribunenewspaper.com/?cat=475">Culture <strong class="caret"></strong></a>
<ul class="dropdown-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown-submenu menu-item-26853"><a data-test="joie" href="http://www.signaltribunenewspaper.com/?cat=21">Art</a>
<ul class="dropdown-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26854"><a href="http://www.signaltribunenewspaper.com/?cat=575">Imitating Life</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26855"><a href="http://www.signaltribunenewspaper.com/?cat=521">In Living Color</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26784"><a href="http://www.signaltribunenewspaper.com/?cat=22">Around Town</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28264"><a href="http://www.signaltribunenewspaper.com/?cat=13">Commentary</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26789"><a href="http://www.signaltribunenewspaper.com/?cat=490">Full Issue</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26779"><a href="http://www.signaltribunenewspaper.com/?page_id=4">General Information</a></li>
</ul></div></div><div class="btn-toggle-nav pull-right"><button type="button" class="btn menu-btn" data-toggle="collapse" data-target=".nav-collapse" title="Open the menu"><span class="icon-bar"></span><span class="icon-bar"></span><span class="icon-bar"></span> </button></div>          			</div><!-- /.row-fluid -->
          		</div><!-- /.navbar-inner -->
        	</div><!-- /.navbar resp -->
      	</div><!-- /.navbar-wrapper -->
    	  		</header>
  		<div id="main-wrapper" class="container">

    <div class="tc-hot-crumble container" role="navigation"><div class="row"><div class="span12"><div class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><span class="trail-begin"><a href="http://www.signaltribunenewspaper.com" title="Signal Tribune Newspaper" rel="home" class="trail-begin">Home</a></span> <span class="sep">&raquo;</span> <a href="http://www.signaltribunenewspaper.com/?cat=603" title="City of Signal Hill 90th Anniversary">City of Signal Hill 90th Anniversary</a> <span class="sep">&raquo;</span> <span class="trail-end">Larger Than Life</span></div></div></div></div>
    <div class="container" role="main">
        <div class="row column-content-wrapper">

            
                <div id="content" class="span12 article-container tc-gallery-style">

                    
                        
                                                                                    
                                                                    <article id="post-25089" class="row-fluid post-25089 post type-post status-publish format-standard hentry category-city-of-signal-hill-90th-anniversary">
                                                <header class="entry-header">
          <h1 class="entry-title ">Larger Than Life <span class="comments-link"><a href="#tc-comment-title" title="1 Comment(s) on Larger Than Life" data-disqus-identifier="javascript:this.page.identifier"><span class="tc-comment-bubble default-bubble">1 </span></a></span></h1><div class="entry-meta">This entry was posted in <a class="btn btn-mini btn-tag" href="http://www.signaltribunenewspaper.com/?cat=603" title="View all posts in City of Signal Hill 90th Anniversary"> City of Signal Hill 90th Anniversary </a> on <a href="http://www.signaltribunenewspaper.com/?m=20140912" title="12:51 pm" rel="bookmark"><time class="entry-date updated" datetime="2014-09-12T12:51:34+00:00">September 12, 2014</time></a> <span class="by-author">by <span class="author vcard"><a class="url fn n" href="http://www.signaltribunenewspaper.com/?author=1" title="View all posts by admin" rel="author">admin</a></span></span> </div><hr class="featurette-divider __before_content">        </header>
                  <section class="entry-content ">
              <p><strong>Ashley Fowler<br />
Staff Writer</strong></p>
<p>Signal Hill has hosted a number of colorful characters over the years. Among them, the memory of the multifaceted “Kid Mexico” lives on.<br />
Tod “Kid Mexico” Faulkner was born on Nov. 22, 1900 in Hope, New Mexico. Shortly, thereafter the family moved to Taft, California, near Bakersfield.<br />
As a child, Faulkner was already a boxing enthusiast and by 14, he was the state’s bantam-weight champ. He became welter-weight champ at 17 and by 25 held the middle-weight title. <span id="more-25089"></span></p>
<p>One night in the ring an announcer flubbed “the kid from New Mexico,” launching the snappy moniker “Kid Mexico.” Promoters gobbled up the name and accompanying persona. It was one to be remembered.<br />
Out of 387 fights, Faulkner lost only 11. Bert Colima, a well-known fighter from Whittier, beat him three of those times. The rivals boxed before sellout crowds in 1921, 1922 and 1925.<br />
After the last defeat, the Los Angeles Times called him “poor old Kid Mexico.”<br />
But he didn’t stop. He wouldn’t retire from the ring until 1936, when he decided to become a fight promoter. During that time, there were various disputes with the boxing commission over his organizing fights without a license. He continued promoting into the 1940s.<br />
In 1932, he met his future wife Edna at the Majestic Ballroom, located at the Pike. She was just 16 years old at the time– half his age. Within a year they were married.<br />
Faulkner worked in the oil fields after that, until he decided he could make more money in the entertainment business.<br />
He opened up a café, a bar, a bowling alley, a taxi-dancing hall and a bingo parlor. On Sunday nights, he would call the glitziest of his star-studded little black book to entertain Signal Hill residents as they patronized his joints.<br />
“His personality certainly warranted hanging out with celebrities,” neighbor Raymond Tropeano said. “He was that kind of guy. He wanted to always be in the thick of things, and I think that was just the way he was.”<br />
Faulkner lived across the street from his entertainment emporium in the 14-room house he’d built for his wife. They had two sons, Tod Jr. and Harley. His home was filled with pictures and memorabilia from his boxing heyday– photos of him with Bing Crosby and Bob Hope in front of his Signal Hill home, for example.<br />
“He had all kinds of really neat stuff that, as a kid, we used to love to mess around on– old slot machines and jukeboxes,” Tropeano said. “We also loved looking at his old pictures of him with his celebrity buddies.”<br />
Faulkner knew everyone. He had friends in Hollywood, in City Hall and law-enforcement, and some said that he had enough politicians on bankroll to keep his doors open.<br />
He campaigned vigorously for his favorite officials; he was even reported to mow a woman’s lawn to convince her to support his candidate.<br />
He made a substantial amount of money during that time. Operating outside of the law, Faulkner brought the people of Signal Hill the entertainment they were craving.<br />
“There was a lot of underground stuff that he was involved with. I remember the slot machines in his house, which were illegal at the time, and I remember that so distinctly,” Tropeano said. “He even had his own ‘Kid Mexico’ casino tokens. There were certainly things he was doing that weren’t quite so legal.”<br />
Despite his shady dealings, or perhaps because of them, Faulkner was generous to folks in his community<br />
“At Christmas time his most local charitable activity was a party for the kids of Signal Hill,” neighbor Marjorie Grommé remembered. “He collected loads of gifts throughout the years, including bicycles, dolls, games– just anything that would appeal to kids.”<br />
For 38 years, from 1941 to 1979, his Christmas parties brought joy to the area’s children. He would give away more than 10,000 toys every year. Celebrities like Hopalong Cassidy and Jack Dempsey helped him officiate his big giveaway.<br />
“You felt really comfortable with the guy,” Tropeano said. “He was very warm and welcoming and generous. He was nice to every kid.”<br />
The press also came in droves. They would follow his goings-on, run-ins with law-enforcement, or his large charitable donations.<br />
In 1951, he was accused of registering voters who didn’t live in Signal Hill to defeat an anti-gambling initiative that would put an end to his bingo parlor.  He pled guilty to the charges, was fined $500 and given three years’ probation. The initiative passed and, without the gambling, his business quickly dried up.<br />
Faulkner and his wife then moved to Laguna Beach in 1952, just three years before she died of cancer in their living room. She was 36.<br />
Faulkner married again, shortly. But in 1970, he moved back to Signal Hill and opened a “Kid Mexico” museum in his old house, charging locals $2 to view his collection of photos and memorabilia. Among the artifacts displayed hung a painting by silent-film star William S. Hart and a chair that had belonged to Western-film actor Tom Mix.<br />
In 1979, a reporter from the Press-Telegram attended Faulkner’s final Christmas party. He was asked how he spent his time, and he answered, “I think of women during the day, eat out most of the time, and go dancing at night.”<br />
Faulkner was 85 and living in Hemet when he died from a heart attack. His obituary in the local newspaper in 1985 read, “According to whom you chose to believe, he was a hero or a bum. A colorful character or a shady figure.”<br />
The people of Signal Hill who still remember him, mostly children who grew up receiving his Christmas gifts, say he was warm and generous, and his larger-than-life personality is etched into some of their favorite childhood memories. They remember him best as the life of the party. </p>
<p>Information from this story was provided by the Historical Society of Long Beach, based on a script used during the organization’s annual cemetery tour.</p>
                                      </section><!-- .entry-content -->
                                            </article>
                                
                            
                        
                    <hr class="featurette-divider __after_loop">
<div id="comments" class="comments-area" >
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/?p=25089&amp;cpage=1#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.signaltribunenewspaper.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='25089' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d7c5d6819e" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="197"/></p>				</form>
					</div><!-- #respond -->
		<h2 id="tc-comment-title" class="comments-title">One thought on &ldquo;<span>Larger Than Life</span>&rdquo;</h2>              <ul class="commentlist">
                        <li class="comment even thread-even depth-1" id="li-comment-1641569">

            <article id="comment-1641569" class="comment"><div class="row-fluid"><div class="comment-avatar span2"><img alt='' src='http://2.gravatar.com/avatar/50db87c8065dcb0b89ff1ebd3c87bd7a?s=80&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/50db87c8065dcb0b89ff1ebd3c87bd7a?s=160&amp;d=mm&amp;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' /></div><div class="span10"> <header class="comment-meta comment-author vcard"><cite class="fn"><a href='http://Was%20recently%20taken%20down%20when%20entity%20that%20provided%20our%20server%20made%20upgrades.%20%20In%20process%20of%20getting%20our%20own.' rel='external nofollow' class='url'>Dennis McCall</a>  </cite> <a class="comment-date" href="http://www.signaltribunenewspaper.com/?p=25089&#038;cpage=1#comment-1641569"><time datetime="2017-02-22T01:15:52+00:00">February 22, 2017 at 1:15 am</time></a></header>  <section class="comment-content comment"><p>I am a volunteer at the West Kern Oil Museum in Taft CA.  One of our exhibits depicts boxing in the early days and includes an old fight card poster depicting Kid Mexico.  My dad was an outstanding amateur boxer and remembered the Kid and long ago told the story of how Tod got his ring monicker.  In the late 70s while serving as editor of the local newspaper (Daily Midway Driller) I got a call from Kid Mexico.  He was closing his bowling alley and had a large collection of stuffed animals, skates and bowling stuff and wanted to hold a giveaway from kids in Taft.  My city editor worked with Tod on the event.  We held it in our parking lot.  It was a huge hit.  Tod truly was in his element.  I&#8217;ll never forget how excited he was.  He told us he just wanted to give back to the community that meant so much to him as a kid, especially his boxing career.  I&#8217;m retired now and a few months ago someone left a box of photos at the Midway Driller office with a note to give them to me.  The Oil Museum is adding some of those photos and information about Kid Mexico to our exhibit.  I&#8217;d like to use part or all of your story on Kid Mexico.  Thank you.</p>
</section></div></div></article>          <!-- //#comment-## -->
        </li><!-- #comment-## -->
              </ul><!-- .commentlist -->
            </div><!-- //#comments .comments-area -->

        
          <hr class="featurette-divider __after_loop">
        <nav id="nav-below" class="navigation" role="navigation">

              <h3 class="assistive-text">
                Post navigation              </h3>

              <ul class="pager">
                                  <li class="previous">
                    <span class="nav-previous">
                      <a href="http://www.signaltribunenewspaper.com/?p=25087" rel="prev"><span class="meta-nav">&larr;</span> City of Long Beach plans community review process for Civic Center request for proposals</a>                    </span>
                  </li>
                                                  <li class="next">
                    <span class="nav-next">
                        <a href="http://www.signaltribunenewspaper.com/?p=25091" rel="next">LBPD makes three arrests, 19 citations at checkpoint <span class="meta-nav">&rarr;</span></a>                    </span>
                  </li>
                              </ul>

          </nav><!-- //#nav-below .navigation -->

        
        
                </div><!--.article-container -->

           
        </div><!--.row -->
    </div><!-- .container role: main -->

    
</div><!-- //#main-wrapper -->

  		<!-- FOOTER -->
  		<footer id="footer" class="">
  		 					<div class="container footer-widgets  no-widget-icons">
                    <div class="row widget-area" role="complementary">
												
							<div id="footer_one" class="span4">
																
										<aside id="social-widget-2" class="widget Social_Widget"><h3 class="widget-title">Follow Us!</h3><div class="socialmedia-buttons smw_left"></div></aside>
																							</div><!-- .{$key}_widget_class -->

						
							<div id="footer_two" class="span4">
																															</div><!-- .{$key}_widget_class -->

						
							<div id="footer_three" class="span4">
																															</div><!-- .{$key}_widget_class -->

																	</div><!-- .row.widget-area -->
				</div><!--.footer-widgets -->
				    				 <div class="colophon">
			 	<div class="container">
			 		<div class="row-fluid">
					    <div class="span3 social-block pull-left"><span class="tc-footer-social-links-wrapper" ><a class="social-icon icon-feed" href="http://www.signaltribunenewspaper.com/?feed=rss" title="Subscribe to my rss feed"  ></a><a class="social-icon icon-twitter" href="https://twitter.com/SignalTribune" title="Follow me on Twitter" target=_blank ></a><a class="social-icon icon-facebook" href="https://www.facebook.com/signal.tribune" title="Follow me on Facebook" target=_blank ></a><a class="social-icon icon-youtube" href="https://www.youtube.com/channel/UCURvDuI0JRY7wbkhQ52w1Ew" title="Follow me on Youtube" target=_blank ></a><a class="social-icon icon-linkedin" href="https://www.linkedin.com/pub/neena-strichart/80/5b1/5ba" title="Follow me on LinkedIn" target=_blank ></a></span></div><div class="span6 credits"><p>&middot; <span class="tc-copyright-text">&copy; 2017</span> <a href="http://www.signaltribunenewspaper.com" title="Signal Tribune Newspaper" rel="bookmark">Signal Tribune Newspaper</a> &middot; <span class="tc-credits-text">Designed by</span> <a href="http://presscustomizr.com/">Press Customizr</a> &middot; <span class="tc-wp-powered-text">Powered by</span> <a class="icon-wordpress" target="_blank" href="https://wordpress.org" title="Powered by WordPress"></a> &middot;</p></div><div class="span3 backtop"><p class="pull-right"><a class="back-to-top" href="#">Back to top</a></p></div>	      			</div><!-- .row-fluid -->
	      		</div><!-- .container -->
	      	</div><!-- .colophon -->
	    	  		</footer>
    </div><!-- //#tc-page-wrapper -->
		<!-- AdSense Manager v4.0.3 (0.334 seconds.) -->	<div style="display:none">
	<div class="grofile-hash-map-50db87c8065dcb0b89ff1ebd3c87bd7a">
	</div>
	</div>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201708'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.signaltribunenewspaper.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.1'></script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/plugins/aesop-story-engine/public/assets/js/ai-core.min.js?ver=1.9.4'></script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/themes/customizr/inc/assets/js/modernizr.min.js?ver=3.4.33'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-content/plugins/jetpack/_inc/facebook-embed.js'></script>
<script type='text/javascript' src='http://www.signaltribunenewspaper.com/wp-includes/js/wp-embed.min.js?ver=4.6.3'></script>
<script type='text/javascript' src='http://stats.wp.com/e-201708.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.3.2',blog:'1534840',post:'25089',tz:'-4.5',srv:'www.signaltribunenewspaper.com'} ]);
	_stq.push([ 'clickTrackerInit', '1534840', '25089' ]);
</script>
	</body>
	</html>